大智慧公式成交换手level-2副图指标公式源码

2019-02-10 18:46:06  阅读 189 次 评论 0 条
 大智慧公式成交换手level-2副图指标公式源码

{换手率成交量分析解盘}
VARIABLE:K=1;
VAR1:=SUM(VOL,0);
VAR2:=VAR1/CAPITAL;
N:=FLOOR(VAR2);
IF N=REF(N,1)+1 THEN BEGIN
STICKLINE(C,0,80,4,1);
DRAWTEXT(C,80,' 第'),ALIGN0,COLORGREEN;
DRAWTEXT(C,70,' '+NUMTOSTR( N)),ALIGN0,COLORRED;
DRAWTEXT(C,60,' 次'),ALIGN0,COLORGREEN;
DRAWTEXT(C,50,' 完'),ALIGN0,COLORGREEN;
DRAWTEXT(C,40,' 全'),ALIGN0,COLORGREEN;
DRAWTEXT(C,30,' 换'),ALIGN0,COLORGREEN;
DRAWTEXT(C,20,' 手'),ALIGN0,COLORGREEN;
DRAWTEXT(C,10,' '+NUMTOSTR( K)+'天'),ALIGN0,COLORGREEN;
K:=1;
END
ELSE
K:=K+1;
日换手:SUM(VOL,1)*100/CAPITAL,colorf0f000,LINETHICK0 ;
五日换手:SUM(VOL,5)*100/CAPITAL,colorf0f000,LINETHICK0 ;
十日换手:SUM(VOL,10)*100/CAPITAL,colorf0f000,LINETHICK0 ;
二十日换手:SUM(VOL,20)*100/CAPITAL,colorf0f000,LINETHICK0 ;
百日换手:SUM(VOL,100)*100/CAPITAL,colorf0f000,LINETHICK0 ;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交量(手):VOL,ColorC700FF,LINETHICK0;
主动买盘:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORred,
LINETHICK0;
主动卖盘:IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2)),color66ff00,
LINETHICK0;
{解盘:N=75 25 100 }
REFLINE: 0, 25, 75, 100;
Var1:=IF(MA(CLOSE,88),1,0);
Var2:=1/WINNER(CLOSE);
Var3:=100-ABS((CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100);
HSL:=vol/capital*100;
量能:=SUM(HSL,N);
涨幅1:=100*(CLOSE-REF(CLOSE,N))/REF(CLOSE,N);
流通市值:=capital*c;
AH:=HHV(流通市值,N);
AL:=LLV(流通市值,N);
t1:=if(HSL<=2,1,0);
t2:=if(HSL>2 AND HSL<3,1,0);
t3:=if(HSL>3 AND HSL<5,1,0);
t4:=if(HSL>5 AND HSL<8,1,0);
t5:=if(HSL>8 AND HSL<15,1,0);
t6:=if(HSL>15 AND HSL<25,1,0);
t7:=if(HSL>=25,1,0);
sss:=100/4;
i:=0;
IF  HSL<=2  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),'日换手率在1%--2%,股价属于成交低靡,属于冷门股。日换手率成交小于3%的成交额称为“成交无量”。'),Color00FFFF,ALIGN2; i:=i+1; 
END
IF  HSL>2 AND HSL<3  THEN  BEGIN  DRAWTEXT(c>0 and
DISPSTATUS=2,100-(sss*i),'日换手率在2%--3%,股价属于成交温和,属于备份股。'),Color00FFFF,ALIGN2;
i:=i+1; 
END
IF  HSL>3 AND HSL<5  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),' 日换手率在3%--5%,股价属于成交活跃,表示有庄家在积极活动,属于热门股。把10日平均换手率大于3%或大于5%,而后又缩量至换手率小于3%高度控盘的个股作为选股条件。'),Color00FFFF,ALIGN2; i:=i+1;  END
IF  HSL>5 AND HSL<8  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),' 日换手率在5%--8%, 大于7%,常常超过10%,属于股价成交带量,表明筹码在急剧换手。发生在低位或是通过第一阻力区,很可能是强庄积极进货。'),Color00FFFF,ALIGN2;
i:=i+1;  END
IF  HSL>8 AND HSL<15  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),' 日换手率大于8%--15%,股价属于成交放量。'),ColorFFFFF5,ALIGN2; i:=i+1;  END
IF  HSL>15 AND HSL<25  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),' 日换手率大于15%--25%,股价属于成交巨量,发生在高位或高位缩量横盘之后,很可能是庄家出货。'),Color00FFFF,ALIGN2;
i:=i+1;  END
IF  HSL>=25  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),' 日换手率大于25%价属于成交怪异;周换手率大于25% 属于成交活跃。'),ColorFFFFFF,ALIGN2; i:=i+1;  END
IF  量能>3*N AND 涨幅1>3*N  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),'继续大涨'),ColorFF00FF,ALIGN2; i:=i+1;  END
IF  量能<0.5*N AND 涨幅1<N  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),'继续小涨'),ColorFFFF00,ALIGN2; i:=i+1;  END
IF  量能<0.5*N AND 涨幅1>-N AND 涨幅1>0  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),'继续小跌'),ColorFFFF00,ALIGN2; i:=i+1;  END
IF  量能>3*N AND 涨幅1<-3*N  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),'继续大跌'),ColorFF00FF,ALIGN2; i:=i+1;  END
IF  ((量能>3*N AND 涨幅1<N) OR (量能<0.5*N AND 涨幅1>3*N)
OR (量能>3*N AND 涨幅1>-N AND 涨幅1<0) OR (量能<0.5*N AND 涨幅1<-3*N))  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),'注意反转:股价高位向下反转,中位横盘杀跌,低位向上反转。'),ColorFFFFF5,ALIGN2;
i:=i+1;  END
IF  涨幅1>0 and 流通市值<=AL  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),'流通市值减小,涨幅加大'),Color00FFFF,ALIGN2; i:=i+1;  END
IF  涨幅1<=0 and 流通市值<=AL  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),'流通市值加大,涨幅减小'),Color00FFFF,ALIGN2; i:=i+1;  END;
DRAWTEXTREL(20 ,50 ,'趋势看周线' );
DRAWTEXTREL(20 ,200 ,'选股看日线' );
DRAWTEXTREL(20 ,350 ,'买股看时线' );

投资市场成功的铁律:大道至简,简单的才是最有效的!只有简单才最具有操作性,只有简单才具有盈利的稳定性。真正造成你账户持续不断亏损,最大的罪魁祸首就是你太复杂:手多冲动,急躁拖拉,不服输无耐心,心存侥幸,逆势孤注一掷。实盘成功秘决是:简单合理进离场规则,机械重复,长期坚持。当你把简单本质做到了极致,必将成为实盘市场的永久大赢家。大道至简,实盘就是这么简单,只有到了这个境界才能实现财务自由。

势至简高智稳管道线突破系统最新版免费下载:(版本:81.02 大小: 8.20 MB 系统:windows )

势至简高智稳系统免费下载: 本地免费下载

简单到极致的买股神器,势至简高智稳管道线系统免费下载


本文地址:http://zhibiaolu.com/post/8760.html
温馨提示:本站所有资源均来自互联网,如果侵犯你的版权请通知本站,我们会在24小时内删除相关资源!

发表评论


表情

还没有留言,还不快点抢沙发?