大智慧公式星座掌控level-2副图指标公式源码

2019-02-10 18:41:08  阅读 133 次 评论 0 条

 大智慧公式星座掌控level-2副图指标公式源码

{十二星座·神獒赢富机构版分时监控系统}

{input:N(68,0,200),N1(1,0,5),N2(-10,-10,0),P(9,1,100),DDF(18,1,100),R1(5,1,100),R2(10,1,100),高(30,1,100),宽(22,1,100),期(7,1,100),PQ(7,1,10),转(25,1,1000),本(5,1,100),入(25,1,30),出(22,1,30),NVV(5,1,100);}
a1:=((CLOSE - (LLV(LOW,27))) / ((HHV(HIGH,27)) - (LLV(LOW,27)))) * 100;
a2:=SMA(a1,9,1);
a3:=SMA(a2,5,1);
a4:=SMA(a3,3,1);
a5:=(3 * a3) - (2 * a4);
a6:=(((MA(CLOSE,68)) - ((MA(CLOSE,68)) / 3)));
a7:=((CLOSE / a6) - 1) * 100;
a8:=BETWEEN(a7,1,-10);
a9:=IF((a8 > 1),5,88);
a10:=(MA(WINNER(CLOSE),9)) * 100;
a11:=(CROSS(a2,2.5)) * 85;
出击:IF((a11 > 0),100,0),linethick3,colorred;
DRAWTEXT((出击 > 0),80,'出击'),colorYellow;
a12:=IF(((a11 > 0) OR (出击 > 0)),2,20);
a13:=(2);
a6:=(((3 * (SMA(a1,5,1))) - (2 * (SMA((SMA(a1,5,1)),3,1)))));
{买点准备:IF(((a6 <= 9) AND (a5 < 38)),62,0),linethick1,colorGreen;}
{买入时间:IF(((CROSS(a6,a13)) AND (a5 < 20)),88,0),linethick2,colorCyan;}
a14:=((REF(((((LOW + OPEN) + CLOSE) + HIGH) / 4),1)));
a15:=(SMA(ABS((LOW - a14)),13,1)) / (SMA((MAX((LOW - a14),0)),10,1));
a16:=EMA(a15,10);
a19:=((((HHV(HIGH,9)) - CLOSE) / ((HHV(HIGH,9)) - (LLV(LOW,9)))) * 100) - 70;
a20:=(SMA(a19,9,1)) + 100;
a21:=((CLOSE - (LLV(LOW,9))) / ((HHV(HIGH,9)) - (LLV(LOW,9)))) * 100;
a22:=SMA(a21,3,1);
a23:=(SMA(a22,3,1)) + 100;
a24:=a23 - a20;
a25:=(IF((a24 > 100),(a24 - 100),0)) * 1.2;
a26:=MA(a25,2);
a27:=((CLOSE - (REF(CLOSE,1))) / (REF(CLOSE,1))) * 100;
a28:=((EMA(CLOSE,12)) - (EMA(CLOSE,26))) * 100;
a29:=EMA(a28,9);
a30:=2 * (a28 - a29);
DRAWTEXT((((a28 < -50) AND (a27 > 7)) AND (a28 < a29)),28,'底'),linethick2,colorRed;
DRAWTEXT((((a28 < -50) AND (a27 > 7)) AND (a28 >= a29)),5,'追'),colorWhite;
STICKLINE(((a28 < -50) AND (a27 > 7)),0,10,3,0),ColorFFFF66;
a14:=((ZIG(3,34)));
进入:(((REF(a14,2)) > (REF(a14,1))) AND (a14 > (REF(a14,1)))) * 80;
出货:(((REF(a14,2)) < (REF(a14,1))) AND (a14 < (REF(a14,1)))) * 108,linethick2,colorRed;
DRAWTEXT((出货 > 28),88,'顶'),linethick1,colorYellow;
DRAWTEXT((进入 > 28),39,'底'),linethick1,colorYellow;
a31:=((HIGH + LOW) + (3 * CLOSE)) / 5;
a32:=EMA(a31,5);
a33:=EMA(a31,21);
a34:=MA(CLOSE,60);
a35:=(COUNT((CLOSE < a34),33)) > 31;
a36:=CROSS(CLOSE,a34);
a37:=(CLOSE / (REF(CLOSE,1))) > 1.045;
a38:=IF((((((CLOSE / (REF(CLOSE,1))) - 1) * 100) >= 5) AND (CLOSE > (OPEN * 1.04))),20,0);
a39:=BARSLAST(a38);
a40:=IF((((a39 <= 13) AND (LOW < (REF(OPEN,a39)))) AND ((CLOSE / (REF(CLOSE,1))) <= 0.98)),10,0);
a41:=(((COUNT((CLOSE < (REF(CLOSE,1))),4)) >= 3) OR ((COUNT((CLOSE < (REF(CLOSE,1))),5)) >= 4)) OR ((COUNT((CLOSE < (REF(CLOSE,1))),6)) >= 5);
a42:=(((((HHV(HIGH,5)) / LOW) - 1) * 100) > 18) OR (((((HHV(HIGH,7)) / LOW) - 1) * 100) > 18);
超跌:IF((((a41 AND (a26 < 0.3)) AND a42) AND (CLOSE <= (REF(CLOSE,1)))),50,0),linethick2,colorWhite;
a43:=(100 * ((HHV(HIGH,5)) - CLOSE)) / ((HHV(HIGH,5)) - (LLV(LOW,5)));
a44:=(100 * ((HHV(HIGH,6)) - CLOSE)) / ((HHV(HIGH,6)) - (LLV(LOW,6)));
a45:=80 - (((a43 * 3) + (a44 * 2)) / 5);
低吸:IF((((超跌 OR a40) AND (a26 < 0.3)) AND (a45 < -18)),65,0),linethick2,ColorFFFF99;
a47:=REF(CLOSE,2);
a48:=((SMA((MAX((CLOSE - a47),0)),7,1)) / (SMA(ABS((CLOSE - a47)),7,1))) * 100;
超卖1:IF((a48 < 12),25,0),linethick3,colorred;
a49:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),7,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),7,1))) * 100;
超卖2:IF((a49 < 12),30,0),linethick3,colorblue;
派发:STICKLINE((a48 > 90),(a48 + 1),(a48 - 1),38,0),colorRed;
闪:IF(((a48 < (REF(a48,1))) AND (a48 > 88)),a48,0),colorRed;
DRAWTEXT((闪 > 88),68,'出'),colorYellow;
a50:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),5,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),5,1))) * 100;
a51:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),10,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),10,1))) * 100;
a52:=a50 AND (a50 > a51);
a53:=LLV(LOW,10);
a54:=HHV(HIGH,25);
a55:=EMA((((CLOSE - a53) / (a54 - a53)) * 4),4);
{DRAWTEXT((CROSS(a55,0.3)),25,'买'),ColorFFFFCC;}
DRAWTEXT((CROSS(3.6,a55)),95,'卖'),Colorgreen;
a56:=(MA(HIGH,30)) * (1 + (22 / 100));
a57:=(MA(LOW,30)) * (1 - (22 / 100));
a58:=CLOSE < (REF(CLOSE,3));
a59:=COUNT((a58 = 1),30);
STICKLINE((a59 > 25),38,20,3,1),colorYellow;
a60:=CLOSE > (REF(CLOSE,3));
a61:=COUNT((a60 = 1),30);
STICKLINE((a61 > 22),38,20,3,1),colorGreen;
a62:=((CLOSE - (LLV(LOW,36))) / ((HHV(HIGH,36)) - (LLV(LOW,36)))) * 100;
a63:=SMA(a62,3,1);
a64:=SMA(a63,3,1);
a65:=SMA(a64,3,1);
波:(a64),colorRed;
段:(a65),colorGreen;
a66:=(CROSS(a64,a65)) AND (a64 < 12);
DRAWTEXT(((FILTER(a66,10)) = 1),20,'㊣'),linethick4,coloryellow;
STICKLINE(((FILTER(a66,10)) = 1),0,50,2,0),colorYellow;
a67:=(CROSS(a65,a64)) AND (a64 > 90);
STICKLINE(((FILTER(a67,5)) = 1),100,60,2,0),colorYellow;
DRAWTEXT(((FILTER(a67,5)) = 1),78,'顶'),linethick3,colorYellow;
a68:=((CROSS(a63,a64)) AND (a64 > 82)) AND (a64 > a65);
STICKLINE(a68,100,68,3,0),ColorF00FF0;
a69:=((CLOSE - (LLV(CLOSE,124))) / ((HHV(CLOSE,124)) - (LLV(CLOSE,124)))) * 100;
a70:=a69 = 0;
a71:=IF(((CLOSE / COST(5)) < 0.7),1,0);
a72:=LLV(HIGH,240);
a73:=(100 * (CLOSE - a72)) / a72;
a74:=a73 < 0;
a75:=IF(((CLOSE / COST(26)) < 0.7),1,0);
a76:=((a71 OR a75) AND a70) AND a74;
a77:=((CLOSE - (MA(CLOSE,13))) / (MA(CLOSE,13))) * -100;
a78:=((CLOSE - (LLV(LOW,13))) / ((HHV(HIGH,13)) - (LLV(LOW,13)))) * 100;
a79:=SMA(a78,3,2);
a80:=SMA(a79,3,2);
a81:=SMA(a80,5,1);
a82:=IF(((CLOSE / COST(10)) < 0.65),1,0);
底部来临:IF(((FILTER(a76,10)) = 1),120,0),linethick2,colorGreen;
止跌:(IF(((FILTER(a82,3)) = 1),100,0)) * 50,ColorFFCC66;
牛势股票:(((REF(a77,1)) >= 16) AND (((REF(a77,1)) / a77) >= 1.23)) AND (CROSS(a80,a81)),colorRed;
STICKLINE((牛势股票 > 0),0.9,80,10,0),colorRed;
DRAWTEXT(底部来临,25,'底部买点'),colorGreen;
DRAWTEXT(牛势股票,68,'牛势再现'),colorWhite;
DRAWTEXT(止跌,50,'止跌转牛势'),colorYellow;
DRAWTEXTREL(10,800,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;
DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));

==================================================================================================

{XPSRLQJ 分时逐笔}

成交量:=SUM(TRANSACTVOL(1,0),0)+SUM(TRANSACTVOL(2,0),0);
特买:SUM(TRANSACTVOL(1,3),0)/总成交量*100,color0000ff,PRECIS0;
特卖:SUM(TRANSACTVOL(2,3),0)/总成交量*100,color00ff00,PRECIS0;
大买:(SUM(TRANSACTVOL(1,2),0)-SUM(TRANSACTVOL(1,3),0))/总成交量*100,colorff00ff,PRECIS0;
大卖:(SUM(TRANSACTVOL(2,2),0)-SUM(TRANSACTVOL(2,3),0))/总成交量*100,colorabff00,PRECIS0;
中买:(SUM(TRANSACTVOL(1,1),0)-SUM(TRANSACTVOL(1,2),0))/总成交量*100,colorff88ff,PRECIS0;
中卖:(SUM(TRANSACTVOL(2,1),0)-SUM(TRANSACTVOL(2,2),0))/总成交量*100,colorabffab,PRECIS0;
DRAWTEXTABS(110,10,'㊣十二星座*神獒赢富㊣'),COLOR00EEff;

=================================================================================================

{XPSRTOP 分时判断}

外盘:DYNAINFO(23),color0000ff,PRECIS0;
内盘:DYNAINFO(22),color00ff00,PRECIS0;
卖单:DYNAINFO(92),colorabffab,PRECIS0;
买单:DYNAINFO(91),colorff88ff,PRECIS0;
总买:DYNAINFO(89),colorff00ff;
总卖:DYNAINFO(90),colorffff00;
DRAWTEXTABS(110,10,'㊣十二星座*神獒赢富㊣'),COLOR00EEff;

==================================================================================================

{XPSRZH 分时逐单  %}

特买:DYNAINFO(95)*100,color0000ff,PRECIS0;
特卖:DYNAINFO(98)*100,color00ff00,PRECIS0;
大买:DYNAINFO(94)*100,colorff00ff,PRECIS0;
大卖:DYNAINFO(97)*100,colorabff00,PRECIS0;
中买:DYNAINFO(93)*100,colorff88ff,PRECIS0;
中卖:DYNAINFO(96)*100,colorabffab,PRECIS0;
DRAWTEXTABS(110,10,'㊣十二星座*神獒赢富㊣'),COLOR00EEff;

=================================================================================================

{神獒四线}

DRAWTEXTREL(50,10,' 代码: '+STKLABEL+'   '+STKNAME+'    日期: '+YEAR+'年'+MONTH+'月 '+DAY+'日 '),linethick2,ColorFFFF80;
DRAWTEXTREL(650,10,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;
a1:=SUM((ORDERVOL(1,3)),0);
a2:=SUM((ORDERVOL(2,3)),0);
a3:=(SUM((ORDERVOL(1,2)),0)) - a1;
a4:=(SUM((ORDERVOL(2,2)),0)) - a2;
a5:=(SUM((ORDERVOL(1,1)),0)) - (SUM((ORDERVOL(1,2)),0));
a6:=(SUM((ORDERVOL(2,1)),0)) - (SUM((ORDERVOL(2,2)),0));
a7:=(SUM((ORDERVOL(1,0)),0)) - (SUM((ORDERVOL(1,1)),0));
a8:=(SUM((ORDERVOL(2,0)),0)) - (SUM((ORDERVOL(2,1)),0));
a9:=(SUM((ORDERVOL(1,0)),0)) + (SUM((ORDERVOL(2,0)),0));
a10:=a7 - a8;
a11:=a5 - a6;
a12:=a3 - a4;
a13:=a1 - a2;
a14:=(SUM((ORDERVOL(1,2)),0)) - (SUM((ORDERVOL(2,2)),0));
a15:=(100 * a7) / a9;
a16:=(100 * a8) / a9;
a17:=(100 * a5) / a9;
a18:=(100 * a6) / a9;
a19:=(100 * a3) / a9;
a20:=(100 * a4) / a9;
a21:=(100 * a1) / a9;
中户筹码:A11,linethick1,colorGreen;
大户筹码:A12,linethick1,colorYellow;
机构筹码:A13,linethick1,ColorFF0000;
主力筹码:A14,linethick2,colorRed;
a22:=(100 * a2) / a9;
a23:=(100 * (SUM((ORDERVOL(1,2)),0))) / a9;
a24:=(100 * (SUM((ORDERVOL(2,2)),0))) / a9;
a25:=(100 * a10) / a9;
a26:=(100 * a11) / a9;
a27:=(100 * a12) / a9;
a28:=(100 * a13) / a9;
a29:=(100 * a14) / a9;
a30:=(a1);
a31:=(a2);
a32:=(a3);
a33:=(a4);
a34:=(a5);
a35:=(a6);
a36:=(a7);
a37:=(a8);
a38:=((SUM((ORDERVOL(1,2)),0)));
a39:=((SUM((ORDERVOL(2,2)),0)));
a40:=(a10);
a41:=500 / (MAX(a30,a31,a32,a33,a34,a35,a36,a37,a40,中户筹码,大户筹码,机构筹码));
a42:=550 / (MAX(a38,a39,主力筹码));
a43:=600 - (a30 * a41);
a44:=600 - (a31 * a41);
a45:=600 - (a32 * a41);
a46:=600 - (a33 * a41);
a47:=600 - (a34 * a41);
a48:=600 - (a35 * a41);
a49:=600 - (a36 * a41);
a50:=600 - (a37 * a41);
a51:=600 - (a38 * a42);
a52:=600 - (a39 * a42);
a53:=600 - (a40 * a41);
a54:=600 - (中户筹码 * a41);
a55:=600 - (大户筹码 * a41);
a56:=600 - (机构筹码 * a41);
a57:=600 - (主力筹码 * a42);
DRAWRECTREL(50,a49,70,600,250),colorYellow;
DRAWRECTREL(70,a50,90,600,9213440),colorYellow;
DRAWRECTREL(90,a53,110,600,(IF((a10 >= 0),3289855,8584960))),colorYellow;
DRAWRECTREL(160,a47,180,600,250),colorYellow;
DRAWRECTREL(180,a48,200,600,9213440),colorYellow;
DRAWRECTREL(200,a54,220,600,(IF((a11 >= 0),3289855,8584960))),colorYellow;
DRAWRECTREL(270,a45,290,600,250),colorYellow;
DRAWRECTREL(290,a46,310,600,9213440),colorYellow;
DRAWRECTREL(310,a55,330,600,(IF((a12 >= 0),3289855,8584960))),colorYellow;
DRAWRECTREL(380,a43,400,600,250),colorYellow;
DRAWRECTREL(400,a44,420,600,9213440),colorYellow;
DRAWRECTREL(420,a56,440,600,(IF((a13 >= 0),3289855,8584960))),colorYellow;
DRAWRECTREL(925,a51,945,600,255),colorYellow;
DRAWRECTREL(945,a52,965,600,9213440),colorYellow;
DRAWRECTREL(965,a57,985,600,(IF((a14 >= 0),3289855,8584960))),colorYellow;
DRAWRECTREL(0,600,445,604,255),colorWhite;
DRAWTEXTREL(18,450,'散户'),ColorDDFFFF;
DRAWTEXTREL(125,450,'中户'),ColorDDFFFF;
DRAWTEXTREL(235,450,'大户'),ColorDDFFFF;
DRAWTEXTREL(345,450,'机构'),ColorDDFFFF;
DRAWTEXTREL(888,450,'主力'),ColorDDFFFF;
DRAWTEXTREL(2,720,'机构买:'+NUMTOSTR(a21)+'%'+' 大户买:'+NUMTOSTR(a19)+'%'+' 中户买:'+NUMTOSTR(a17)+'%'+' 散户买:'+NUMTOSTR(a15)+'%'),colorRed;
DRAWTEXTREL(2,790,'机构卖:'+NUMTOSTR(a22)+'%'+' 大户卖:'+NUMTOSTR(a20)+'%'+' 中户卖:'+NUMTOSTR(a18)+'%'+' 散户卖:'+NUMTOSTR(a16)+'%'),colorGreen;
DRAWTEXTREL(2,860,'机构差:'+NUMTOSTR(a28)+'%'+' 大户差:'+NUMTOSTR(a27)+'%'+' 中户差:'+NUMTOSTR(a26)+'%'+' 散户差:'+NUMTOSTR(a25)+'%'),colorWhite;
DRAWTEXTREL(2,930,'主力差:'+NUMTOSTR(a29)+'%'),colorWhite;


投资市场成功的铁律:大道至简,简单的才是最有效的!只有简单才最具有操作性,只有简单才具有盈利的稳定性。真正造成你账户持续不断亏损,最大的罪魁祸首就是你太复杂:手多冲动,急躁拖拉,不服输无耐心,心存侥幸,逆势孤注一掷。实盘成功秘决是:简单合理进离场规则,机械重复,长期坚持。当你把简单本质做到了极致,必将成为实盘市场的永久大赢家。大道至简,实盘就是这么简单,只有到了这个境界才能实现财务自由。

势至简高智稳管道线突破系统最新版免费下载:(版本:81.02 大小: 8.20 MB 系统:windows )

势至简高智稳系统免费下载: 本地免费下载

简单到极致的买股神器,势至简高智稳管道线系统免费下载


本文地址:http://zhibiaolu.com/post/8635.html
温馨提示:本站所有资源均来自互联网,如果侵犯你的版权请通知本站,我们会在24小时内删除相关资源!

发表评论


表情

还没有留言,还不快点抢沙发?