同花顺软件公式做波段股票主图指标公式源码

2019-02-09 22:53:04  阅读 131 次 评论 0 条

同花顺软件公式做波段股票主图指标公式源码

波段主图源码:

fl:MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)),colorf4e202;
fs:MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),colorf4e202,linethick2;
cg:=IF(MA(CLOSE,17)<fs,fs,MA(CLOSE,17)),colorf4e202,linethick2;
年线:=EMA(C,250);
a:cg-(EMA(C,3)-cg),Color1EFFFF,linethick2;
qq:年线-(EMA(C,3)-年线),colorff80ff,linethick2;
PARTLINE(cg,cg>REF(cg,1),RGB(250,30,250),cg<=REF(cg,1),RGB(40,250,40)),LINETHICK3;

var9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
varaQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
varbQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
varcQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
vardQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,12),12)/EMA(EMA(ABS(MTM),12),12);
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),ColorFF2894;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),Color2828FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),Color2DFF2D;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLORFF4D4D;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,10,0 ),COLORD50000;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLORF20000;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORFF2626;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORFF4D4D;//绿蓝空

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,10,0) ,ColorB7005B;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,ColorD5006A;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,ColorF9007C;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,ColorFF2894;//紫红跟
红持:var9Q,Color2D2DFF;
STICKLINE(var9Q,C,(O+C)/2,10,0),Color0000B7;
STICKLINE(var9Q,C,(O+C)/2,8,0),Color0000D5;
STICKLINE(var9Q,C,(O+C)/2,6,0),Color0000FF;
STICKLINE(var9Q,C,(O+C)/2,4,0),Color2D2DFF;
粉加:varaQ,ColorFF2DFF;
STICKLINE(varaQ,C,(O+C)/2,10,0),ColorB700B7;   
STICKLINE(varaQ,C,(O+C)/2,8,0),ColorD500D5;   
STICKLINE(varaQ,C,(O+C)/2,6,0),ColorF900F9;   
STICKLINE(varaQ,C,(O+C)/2,4,0),ColorFF2DFF;   

白减:varbQ,ColorFFFFFF;   
STICKLINE(varbQ,C,(O+C)/2,10,0),ColorAAAAAA;   
STICKLINE(varbQ,C,(O+C)/2,8,0),ColorCECECE;   
STICKLINE(varbQ,C,(O+C)/2,6,0),ColorF2F2F2;   
STICKLINE(varbQ,C,(O+C)/2,4,0),ColorFFFFFF;
绿抛:vardQ,Color2DFF2D;
STICKLINE(vardQ,O,(O+C)/2,10,0),Color00B700;
STICKLINE(vardQ,O,(O+C)/2,8,0),Color00D500;
STICKLINE(vardQ,O,(O+C)/2,6,0),Color00F900;
STICKLINE(vardQ,O,(O+C)/2,4,0),Color2DFF2D;
黄进:varcQ,Color33FFFF;   
STICKLINE(varcQ,O,(O+C)/2,10,0),Color00B7B7;   
STICKLINE(varcQ,O,(O+C)/2,8,0),Color00D5D5;   
STICKLINE(varcQ,O,(O+C)/2,6,0),Color00FBFB;   
STICKLINE(varcQ,O,(O+C)/2,4,0),Color33FFFF;
RSV:=(C-LLV(L,19))/(HHV(H,19)-LLV(L,19))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
B:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(B=1,5),LOW-0.10,'★ '),Color2D2DFF;
RSV:=(C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
注意:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);
DRAWTEXT(注意 AND A<>1,HIGH*1.05,'◆'),Color00D200;
C3:=REF(C,1);
涨停:IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),Color0080FF;
STICKLINE(涨停,OPEN,CLOSE,10,0),Color004891;
STICKLINE(涨停,OPEN,CLOSE,8,0),Color0055AA;
STICKLINE(涨停,OPEN,CLOSE,6,0),Color006AD5;
STICKLINE(涨停,OPEN,CLOSE,4,0),Color0080FF;

跌停:IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),COLORffee00;
STICKLINE(跌停,OPEN,CLOSE,10,0),COLORff6600;
STICKLINE(跌停,OPEN,CLOSE,8,0),COLORff8800;
STICKLINE(跌停,OPEN,CLOSE,6,0),COLORffcc00;
STICKLINE(跌停,OPEN,CLOSE,4,0),COLORffee00;
MA3:=EMA(C,3);
X1:=REF(EMA(C,3),1);
X2:=(EMA(C,3)-X1)/X1*100;
N1:=BARSLAST(CROSS(X2,0.3));
N2:=BARSLAST(CROSS(0.3,X2));
X3:=CROSS(X2,0.3) OR CROSS(0.3,X2);
STICKLINE(N1<N2,REF(MA3,N1),REF(MA3,N1),5,0), POINTDOT,Color37FFFF,LINETHICK2;
STICKLINE(N2<N1,REF(MA3,N2),REF(MA3,N2),5,0), POINTDOT,ColorFFFF2D,LINETHICK2;


投资市场成功的铁律:大道至简,简单的才是最有效的!只有简单才最具有操作性,只有简单才具有盈利的稳定性。真正造成你账户持续不断亏损,最大的罪魁祸首就是你太复杂:手多冲动,急躁拖拉,不服输无耐心,心存侥幸,逆势孤注一掷。实盘成功秘决是:简单合理进离场规则,机械重复,长期坚持。当你把简单本质做到了极致,必将成为实盘市场的永久大赢家。大道至简,实盘就是这么简单,只有到了这个境界才能实现财务自由。

势至简高智稳管道线突破系统最新版免费下载:(版本:81.02 大小: 8.20 MB 系统:windows )

势至简高智稳系统免费下载: 本地免费下载

简单到极致的买股神器,势至简高智稳管道线系统免费下载


本文地址:http://zhibiaolu.com/post/7132.html
温馨提示:本站所有资源均来自互联网,如果侵犯你的版权请通知本站,我们会在24小时内删除相关资源!

发表评论


表情

还没有留言,还不快点抢沙发?