同花顺软件公式K中行股票主图指标公式源码

2019-02-09 22:51:26  阅读 88 次 评论 0 条

同花顺软件公式K中行股票主图指标公式源码

 

K中行主图源码:

指数:INDEXC,NODRAW,Color1A1AFF ;
ED1:=(-2*REF(C,2)+REF(C,1)+2*C);
ED2:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
ED3:=(-0.8*REF(C,4)-0.8*REF(C,3)-0.2*REF(C,2)+0.8*REF(C,1)+2*C);
JF1:=EMA(EMA(ED1,3,1),3,1);
JF2:=EMA(EMA(ED2,4,1),3,1);
JF3:=EMA(EMA(ED3,4,1),4,1);
M7:EMA(JF1,7,2),ColorFFFFFF;
M14:EMA(JF1,14,2),ColorFF26FF;
M25:EMA(JF1,25,2),ColorFFFF28;
M40:EMA(JF1,40,2),Color00FF00;
ED2:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
JF2:=EMA(EMA(ED2,4,1),3,1);
DRAWICON(CROSS(ED2,JF2),L/1.049,8);
DRAWICON(CROSS(JF2,ED2),H*1.079,12);
CROSS(ED2,JF2);
MA3:=MA(C,3);
X1:=REF(EMA(C,3),1);
X2:=(EMA(C,3)-X1)/X1*100;
N1:=BARSLAST(CROSS(X2,0));
N2:=BARSLAST(CROSS(0,X2));

X3:=CROSS(X2,0) OR CROSS(0,X2);
STICKLINE(N1<N2,REF(MA3,N1),REF(MA3,N1),9,3),ColorFF0BFF,LINETHICK2;
STICKLINE(N2<N1,REF(MA3,N2),REF(MA3,N2),9,3),ColorFFFFFF,LINETHICK2;
VAR1:=(CLOSE+HIGH+LOW)/3;
VAR2:=EMA(VAR1,8);
VAR3:=REF(VAR2,1);
STICKLINE(VAR2>VAR3,VAR2,VAR3,10,0),color00FFFF;
STICKLINE(VAR2<VAR3,VAR2,VAR3,10,0),colorFF0000;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),ColorFFFF1E;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),ColorFFFF1E;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,10,0 ),ColorA2A200;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),ColorBFBF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),ColorDDDD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),ColorF7F700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),ColorFFFF0B;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),ColorFFFF26;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),ColorFFFF42;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,10,0) ,Color0000A6;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,Color0000C4;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,Color0000E1;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,Color0000F0;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,Color0909FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,Color1717FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,Color3E3EFF;
var9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
     STICKLINE(var9Q,C,(O+C)/2,10,0),ColorC60063;
     STICKLINE(var9Q,C,(O+C)/2,8,0),ColorDD006F;
     STICKLINE(var9Q,C,(O+C)/2,6,0),ColorF20079;
     STICKLINE(var9Q,C,(O+C)/2,5,0),ColorFF0B85;
     STICKLINE(var9Q,C,(O+C)/2,3,0),ColorFF1E8E;
     STICKLINE(var9Q,C,(O+C)/2,2,0),ColorFF2894;
     STICKLINE(var9Q,C,(O+C)/2,1,0),ColorFF4DA6;
varaQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
     STICKLINE(varaQ,C,(O+C)/2,10,0),ColorBE00BE;
     STICKLINE(varaQ,C,(O+C)/2,8,0),ColorDE00DE;
     STICKLINE(varaQ,C,(O+C)/2,6,0),ColorEC00EC;
     STICKLINE(varaQ,C,(O+C)/2,5,0),ColorEE00EE;
     STICKLINE(varaQ,C,(O+C)/2,3,0),ColorFF06FF;
     STICKLINE(varaQ,C,(O+C)/2,2,0),ColorFF33FF;
     STICKLINE(varaQ,C,(O+C)/2,1,0),ColorFF55FF;
varbQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
     STICKLINE(varbQ,C,(O+C)/2,10,0),ColorB6B6B6;
     STICKLINE(varbQ,C,(O+C)/2,8,0),ColorC5C5C5;
     STICKLINE(varbQ,C,(O+C)/2,6,0),ColorD5D5D5;
     STICKLINE(varbQ,C,(O+C)/2,5,0),ColorC6C6C6;
     STICKLINE(varbQ,C,(O+C)/2,3,0),ColorE7E7E7;
     STICKLINE(varbQ,C,(O+C)/2,2,0),ColorFFFFFF;
     STICKLINE(varbQ,C,(O+C)/2,1,0),ColorFFFFFF;
varcQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
     STICKLINE(varcQ,O,(O+C)/2,10,0),Color00A6A6;
     STICKLINE(varcQ,O,(O+C)/2,8,0),Color00C4C4;
     STICKLINE(varcQ,O,(O+C)/2,6,0),Color00DDDD;
     STICKLINE(varcQ,O,(O+C)/2,5,0),Color00F0F0;
     STICKLINE(varcQ,O,(O+C)/2,3,0),Color06FFFF;
     STICKLINE(varcQ,O,(O+C)/2,2,0),Color1EFFFF;
     STICKLINE(varcQ,O,(O+C)/2,1,0),Color46FFFF;
vardQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
STICKLINE(vardQ,O,(O+C)/2,10,0),Color00A200;
STICKLINE(vardQ,O,(O+C)/2,8,0),Color00BF00;
STICKLINE(vardQ,O,(O+C)/2,6,0),Color00DD00;
STICKLINE(vardQ,O,(O+C)/2,5,0),Color00F200;
STICKLINE(vardQ,O,(O+C)/2,3,0),Color00FF00;
STICKLINE(vardQ,O,(O+C)/2,2,0),Color1EFF1E;
STICKLINE(vardQ,O,(O+C)/2,1,0),Color3EFF3E;
C3:=REF(C,1);
涨停:IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),Color2DFFFF;
STICKLINE(涨停,OPEN,CLOSE,10,0),Color00CACA;
STICKLINE(涨停,OPEN,CLOSE,8,0),Color00E3E3;
STICKLINE(涨停,OPEN,CLOSE,6,0),Color02FFFF;
STICKLINE(涨停,OPEN,CLOSE,4,0),Color02FFFF;
STICKLINE(涨停,OPEN,CLOSE,2,0),Color2DFFFF;
跌停:IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),Color33FF33;
STICKLINE(跌停,OPEN,CLOSE,10,0),Color00B700;
STICKLINE(跌停,OPEN,CLOSE,8,0),Color00D200;
STICKLINE(跌停,OPEN,CLOSE,6,0),Color00EA00;
STICKLINE(跌停,OPEN,CLOSE,4,0),Color0FFF0F;
STICKLINE(跌停,OPEN,CLOSE,2,0),Color33FF33;
x1:=(C+L+H)/3;
bb14:=ATAN(EMA(x1,14)-REF(EMA(x1,14),1))*3.1416*10;
ema8:=EMA(C,7);
DRAWTEXT(FILTER(bb14>1 AND EMA(x1,14)>REF(EMA(x1,7),1),10),
ema8,'∠45上升'),colorwhite;


投资市场成功的铁律:大道至简,简单的才是最有效的!只有简单才最具有操作性,只有简单才具有盈利的稳定性。真正造成你账户持续不断亏损,最大的罪魁祸首就是你太复杂:手多冲动,急躁拖拉,不服输无耐心,心存侥幸,逆势孤注一掷。实盘成功秘决是:简单合理进离场规则,机械重复,长期坚持。当你把简单本质做到了极致,必将成为实盘市场的永久大赢家。大道至简,实盘就是这么简单,只有到了这个境界才能实现财务自由。

势至简高智稳管道线突破系统最新版免费下载:(版本:81.02 大小: 8.20 MB 系统:windows )

势至简高智稳系统免费下载: 本地免费下载

简单到极致的买股神器,势至简高智稳管道线系统免费下载


本文地址:http://zhibiaolu.com/post/7095.html
温馨提示:本站所有资源均来自互联网,如果侵犯你的版权请通知本站,我们会在24小时内删除相关资源!

发表评论


表情

还没有留言,还不快点抢沙发?