同花顺软件公式调度图股票主图指标公式源码

2019-02-09 22:40:06  阅读 163 次 评论 0 条

同花顺软件公式调度图股票主图指标公式源码

指数:INDEXC,NODRAW,Color1A1AFF ;
ED1:=(-2*REF(C,2)+REF(C,1)+2*C);
ED2:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
ED3:=(-0.8*REF(C,4)-0.8*REF(C,3)-0.2*REF(C,2)+0.8*REF(C,1)+2*C);
CC:=(-2*REF(C,3)+3*REF(C,2)+6*REF(C,1)+7*C)/14;
JF1:=SMA(SMA(ED1,3,1),3,1);
JF2:=SMA(SMA(ED2,4,1),3,1);
JF3:=SMA(SMA(ED3,4,1),4,1);
趋势线:=EMA(JF2,7,2);
工作线:EMA(JF1,14,2),Color0072E3;
生命线:EMA(JF2,25,2),Color28FFFF;
牛熊线:EMA(JF3,40,2),ColorFF8102;
半年线:EMA(JF3,118,2),Color7100E1;
PARTLINE(趋势线,趋势线>REF(趋势线,1),RGB(250,30,250),趋势线<=REF(趋势线,1),RGB(30,250,30)),LINETHICK2;
gjzx:=(H+L+2*C)/4;
blx1:=FORCAST(gjzx,18)-FORCAST(gjzx,4);
blx2:=FORCAST(gjzx,4)-blx1*2;

波浪线:=MA(SLOPE(blx2,3)*0.5+blx2,3),POINTDOT,colormagenta;
var9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
varaQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
varbQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
varcQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
vardQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,10,0 ),ColorAAAAAA;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,10,0 ),ColorCECECE;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),ColorF2F2F2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),ColorFFFFFF;//白减
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,10,0) ,ColorB7005B;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,10,0) ,ColorD5006A;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,ColorF9007C;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,ColorFF2894;//紫红跟
红持:var9Q,Color2D2DFF;
STICKLINE(var9Q,C,(O+C)/2,10,0),Color0000B7;
STICKLINE(var9Q,C,(O+C)/2,10,0),Color0000D5;
STICKLINE(var9Q,C,(O+C)/2,8,0),Color0000FF;
STICKLINE(var9Q,C,(O+C)/2,4,0),Color2D2DFF;   
紫跟:varaQ,ColorFF2894;
STICKLINE(varaQ,C,(O+C)/2,10,0),ColorB700B7;   
STICKLINE(varaQ,C,(O+C)/2,10,0),ColorD500D5;   
STICKLINE(varaQ,C,(O+C)/2,8,0),ColorF900F9;   
STICKLINE(varaQ,C,(O+C)/2,4,0),ColorFF2DFF;
白减:varbQ,ColorFFFFFF;   
STICKLINE(varbQ,C,(O+C)/2,10,0),ColorAAAAAA;   
STICKLINE(varbQ,C,(O+C)/2,10,0),ColorCECECE;   
STICKLINE(varbQ,C,(O+C)/2,8,0),ColorF2F2F2;   
STICKLINE(varbQ,C,(O+C)/2,4,0),ColorFFFFFF;
F:=100*(C-REF(C,1))/REF(C,1);
p1:=IF(C<REF(O,1) AND f<0,1,0);
p2:=IF(C<REF(O,2) AND f<0,1,0);
黄买:varcQ,Color0079F2;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,10,0),Color0055AA;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,10,0),Color0063C6;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,8,0),Color006DDB;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,4,0),Color0079F2;//黄进
兰抛:vardQ,ColorF9A800;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1  AND REF(P2,1)=0,OPEN,CLOSE,10,0),Color996700;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1  AND REF(P2,1)=0,OPEN,CLOSE,10,0),ColorB57A00;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1  AND REF(P2,1)=0,OPEN,CLOSE,8,0),ColorCC8A00;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1  AND REF(P2,1)=0,OPEN,CLOSE,4,0),ColorF9A800;//兰顶
C3:=REF(C,1);
涨停:IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),ColorFF2DFF;
STICKLINE(涨停,OPEN,CLOSE,10,0),ColorAA00AA;
STICKLINE(涨停,OPEN,CLOSE,10,0),ColorD200D2;
STICKLINE(涨停,OPEN,CLOSE,8,0),ColorF900F9;
STICKLINE(涨停,OPEN,CLOSE,4,0),ColorFF2DFF;//粉
跌停:IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),Color33FF33;
STICKLINE(跌停,OPEN,CLOSE,10,0),Color00D200;
STICKLINE(跌停,OPEN,CLOSE,10,0),Color00EA00;
STICKLINE(跌停,OPEN,CLOSE,8,0),Color0FFF0F;
STICKLINE(跌停,OPEN,CLOSE,4,0),Color33FF33;//绿

VAR1:=4*SMA((CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100,4,1)-
3*SMA(SMA((CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100,4,1),3.2,1);
VAR2:=7;
CC:=CROSS(VAR1,VAR2);
DRAWTEXT(CC,L*0.98,'★'),Color7400E8;
卖出:=CROSS(72,SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100);
DRAWTEXT(卖出,H*1.09,'◆'),colorgreen;
BDGD:=CROSS(0.8,H=HHV(H,6));
GDSJ:=BARSLAST(BDGD)+1;
波峰:=REF(H,GDSJ),Color1EFF1E;
BDDD:=CROSS(0.8,L=LLV(L,6));
DDSJ:=BARSLAST(BDDD)+1;
波谷:=REF(L,DDSJ),Color7400E8;
STICKLINE(GDSJ<=8,波峰,波峰,8,0),Color1EFF1E,LINETHICK02;
STICKLINE(DDSJ<=8,波谷,波谷,8,0),Color7400E8,LINETHICK02;
AAA:=(3*C+H+L+O)/6;
VARa:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
TJ1:=VOL=HHV(VOL,10) AND vol>2*REF(VOL,1) AND CLOSE>VARa;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
LB:='——————',LINETHICK04;
DRAWTEXT(立桩量,REF(HIGH,BARSLAST(立桩量)),LB),Color20FFFF,LINETHICK02;
DRAWTEXT(立桩量,REF(LOW,BARSLAST(立桩量)),LB),Color20FFFF,LINETHICK02;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.93,'立桩显'),coloryellow;
立桩显:=IF(BARPOS=BARSCOUNT(C),VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(立桩显>=1,O,C,10,0),Color00A8A8;
STICKLINE(立桩显>=1,O,C,8,0),Color00C6C6;
STICKLINE(立桩显>=1,O,C,6,0),Color00E3E3;
STICKLINE(立桩显>=1,O,C,4,0),Color09FFFF;//黄


投资市场成功的铁律:大道至简,简单的才是最有效的!只有简单才最具有操作性,只有简单才具有盈利的稳定性。真正造成你账户持续不断亏损,最大的罪魁祸首就是你太复杂:手多冲动,急躁拖拉,不服输无耐心,心存侥幸,逆势孤注一掷。实盘成功秘决是:简单合理进离场规则,机械重复,长期坚持。当你把简单本质做到了极致,必将成为实盘市场的永久大赢家。大道至简,实盘就是这么简单,只有到了这个境界才能实现财务自由。

势至简高智稳管道线突破系统最新版免费下载:(版本:81.02 大小: 8.20 MB 系统:windows )

势至简高智稳系统免费下载: 本地免费下载

简单到极致的买股神器,势至简高智稳管道线系统免费下载


本文地址:http://zhibiaolu.com/post/6732.html
温馨提示:本站所有资源均来自互联网,如果侵犯你的版权请通知本站,我们会在24小时内删除相关资源!

发表评论


表情

还没有留言,还不快点抢沙发?