通达信霸王选股副图指标公式源码

2019-01-31 22:35:08  阅读 230 次 评论 0 条

通达信霸王选股副图指标公式源码

{百法百中}
VAR7:=MA(INDEXC,62)<REF(MA(INDEXC,62),1) AND MA(INDEXC,105)<REF(MA(INDEXC,105),1) AND MA(INDEXC,62)<MA(INDEXC,105)*0.98;
VAR8:=MA(INDEXC,32)>MA(INDEXC,6)*1.11 AND MA(INDEXC,24)>MA(INDEXC,6)*1.095;
VAR9:=MA(INDEXC,6)>INDEXC*0.95;
VARA:=H>L*1.078 AND COUNT(H>L*1.078,4)>2;
百法百中:VARA AND (C/MA(C,48)*100<67 OR C/MA(C,50)*100<69) OR VAR7 AND VAR8 AND VAR9 AND C/COST(8)<=0.8 AND COUNT(C=O,2)=0;

{抄底高手}
VAR1:=(C-MA(C,48))/MA(C,48)*100<-30 AND (C-MA(C,70))/MA(C,70)*100<-27 AND COUNT((C-MA(C,48))/MA(C,48)*100<-30 AND (C-MA(C,70))/MA(C,70)*100<-27,2)=1 AND (O-REF(C,1))/REF(C,1)>-0.07 AND COUNT(C=O,6)=0;
VAR2:=(C-DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL))/DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL)*100;
VAR3:=REF(VAR2,1)<-42 AND VAR2>REF(VAR2,1) AND REF(VAR2,1)<REF(VAR2,2) AND VAR2-REF(VAR2,1)>1.8;
抄底高手:(VAR1 OR VAR3);

{乘胜追击}
VAR4:=(WINNER(C)-WINNER(O))>=0.3 AND MA(V,6)/MA(V,26)>=1.9 AND V>REF(V,1) AND COUNT(SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100<20,20)>=1 AND C/MA(C,3)>=1.07;
VAR5:=(WINNER(C)-WINNER(O))>=0.4 AND MA(V,8)/MA(V,45)>=2.5 AND COUNT(SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100<20,20)>=1 AND C/MA(C,3)>=1.05 AND C>MA(C,85) AND V>REF(V,1);
乘胜追击:(VAR4 OR VAR5);

{短线黑马}
VARB:=(C-DMA(C,V/MA(V,4)/4))/DMA(C,V/MA(V,4)/4)*100<-11 AND (DMA(C,V/MA(V,4)/4)-DMA(C,V/MA(V,33)/33))/DMA(C,V/MA(V,33)/33)*100<-22.3 AND (O-REF(C,1))/REF(C,1)>-0.07 AND COUNT(C=O,8)=0;
VARC:=(C-DMA(CLOSE,VOL/MA(VOL,3)/3))/DMA(CLOSE,VOL/MA(VOL,3)/3)*100<-5;
VARD:=(DMA(CLOSE,VOL/MA(VOL,3)/3)-DMA(C,V/MA(V,33)/33))/DMA(C,V/MA(V,33)/33)*100<-18;
VARE:=VARC AND VARD AND (O-REF(C,1))/REF(C,1)>-0.05 AND COUNT(C=O,2)=0 AND SMA(SMA((INDEXC-LLV(INDEXL,250))/(HHV(INDEXH,250)-LLV(INDEXL,250))*100,30,1),50,1)<20;
短线黑马:(VARB OR VARE AND COUNT(VARE,2)=1);

{逆势买入}
VARF:=(C-DMA(C,V/MA(V,4)/4))/DMA(C,V/MA(V,4)/4)*100<-8 AND (DMA(C,V/MA(V,4)/4)-DMA(C,V/MA(V,32)/32))/DMA(C,V/MA(V,32)/32)*100<-21 AND (O-REF(C,1))/REF(C,1)>-0.05 AND COUNT(C=O,8)=0;
VAR10:=SMA(SMA((INDEXC-LLV(INDEXL,275))/(HHV(INDEXH,275)-LLV(INDEXL,275))*100,50,1),40,1);
VAR11:=(C-MA(C,70))/MA(C,70)*100<-23 AND VAR10<23 AND COUNT((C-MA(C,70))/MA(C,70)*100<-23,2)=1 AND (O>C OR O<C) AND O/REF(C,1)>0.96;
逆势买入:(VARF OR VAR11);

{牛市专利}
VAR12:=(C-MIN(REF(C,3)*0.844,REF(C,13)*0.767))/C<0.07 AND SUM(100*V/CAPITAL,3)/3<2.345 AND INDEXC>MA(INDEXC,450) AND MA(INDEXV,61)/MA(INDEXV,80)>0.923 AND C>MA(C,190);
VAR13:=INDEXC>MA(INDEXC,450) AND (C-MA(C,20))/MA(C,20)*100<-16.5 AND MA(INDEXV,61)/MA(INDEXV,80)>0.92
AND C>MA(C,215) AND V/CAPITAL<0.075 AND COUNT(C=O,5)=0;
牛市专利:(VAR12 OR VAR13) AND HHV(C,440)/LLV(C,440)<4;

{市场赢家}
VAR14:=H>L*1.053 AND COUNT(H>L*1.053,5)>2 AND (C/MA(C,30)*100<75 OR C/MA(C,50)*100<78);
VAR15:=DMA(EMA(C,5),SUM(V,8)/2.8/CAPITAL);
市场赢家:REF((C-VAR15)/VAR15*100,1)<-34 AND (C-VAR15)/VAR15*100>REF((C-VAR15)/VAR15*100,1) AND REF((C-VAR15)/VAR15*100,1)<REF((C-VAR15)/VAR15*100,2) AND (C-VAR15)/VAR15*100-REF((C-VAR15)/VAR15*100,1)>1.76  OR VAR14;

{顺势搭轿}
顺势搭轿:(C-MA(C,48))/MA(C,48)*100<-28 AND SMA(MAX(C-REF(C,1),0),12,1)/SMA(ABS(C-REF(C,1)),12,1)*100>23 AND vol>MA(VOL,18) AND COUNT(C=O,6)=0;

{旭日东升}
旭日东升:(C-MA(C,50))/MA(C,50)*100<-23 AND SMA(MAX(C-REF(C,1),0),3,1)/SMA(ABS(C-REF(C,1)),3,1)*100>16 AND CROSS(100*(HHV(H,27)-C)/(HHV(H,27)-LLV(L,27)),79) AND (O>C OR O<C) AND (O-REF(C,1))/REF(C,1)<0.05 AND V>MA(V,23);
 
 


投资市场成功的铁律:大道至简,简单的才是最有效的!只有简单才最具有操作性,只有简单才具有盈利的稳定性。真正造成你账户持续不断亏损,最大的罪魁祸首就是你太复杂:手多冲动,急躁拖拉,不服输无耐心,心存侥幸,逆势孤注一掷。实盘成功秘决是:简单合理进离场规则,机械重复,长期坚持。当你把简单本质做到了极致,必将成为实盘市场的永久大赢家。大道至简,实盘就是这么简单,只有到了这个境界才能实现财务自由。

势至简高智稳管道线突破系统最新版免费下载:(版本:81.02 大小: 8.20 MB 系统:windows )

势至简高智稳系统免费下载: 本地免费下载

简单到极致的买股神器,势至简高智稳管道线系统免费下载


本文地址:http://zhibiaolu.com/post/5874.html
温馨提示:本站所有资源均来自互联网,如果侵犯你的版权请通知本站,我们会在24小时内删除相关资源!

发表评论


表情

还没有留言,还不快点抢沙发?