股票实战精品指标公式股龙tdx通达信K线主图公式源码

2019-01-20 14:27:34  阅读 259 次 评论 0 条

股票实战精品指标公式股龙tdx通达信K线主图公式源码

N:=80;M:=3;

趋势线:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK4;

LYA1:=IF(H> REF(HHV(H,3),1) AND C> REF(C,1),LLV(L,3),IF (L< REF(LLV(L,3),1) AND C< REF(C,1),

HHV(H,3),DRAWNULL)); 

LYA:=IF(LYA1=DRAWNULL,REF(LYA1,1),LYA1);
SNX2:=IF(LYA< H AND  LYA> L,REF(LYA,1),LYA);
BB:=PLOYLINE(C>0,SNX2),COLORGREEN,LINETHICK1;
DRAWICON(CROSS(C,BB),(C+O)/2,1);
DRAWICON(CROSS(BB,C),(C+O)/2,2);
中: EMA(EMA(EMA(HIGH,7),7),1),COLORLIBLUE,LINETHICK1;
中斜:=(EMA(中,2)-REF(EMA(中,2),2))/REF(EMA(中,2),2)*100,NODRAW;
IF(中斜>=0,中,DRAWNULL),COLORRED,LINETHICK2;
下1: 中*0.93,COLORYELLOW,LINETHICK1;
下2: 中*0.87,COLORYELLOW,LINETHICK1; {0.9}
下3:中*0.81,COLORYELLOW,POINTDOT;
上1:中*1.072,COLORYELLOW,LINETHICK1;
上2: 中*1.12,COLORYELLOW,LINETHICK1;
上3:中*1.19,COLORYELLOW,POINTDOT;
T9:=FILTER(COUNT(L<下3,4)>=2,3);
T91:=FILTER(LAST(C<下2,3,3),3);
MACD:="MACD.MACD#DAY"(12,26,9);
周MACD:="MACD.MACD#WEEK"(12,26,9);
IF(MACD>=0,下1,DRAWNULL),COLORRED,LINETHICK2;
IF(周MACD>=0,下2,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT((C-MA(C,13))/MA(C,13)*100<-20 AND C<下3,L,'建');
DRAWTEXT(FILTER(CROSS(MACD,0)OR CROSS(周MACD,0),3),L*0.99,'加')COLORWHITE;
DRAWTEXT(COUNT(MACD>=0 AND 周MACD>=0 AND 中斜>=0,5)=1 AND MACD>=0 AND
周MACD>=0 AND 中斜>=0,L*0.96,'加')COLORMAGENTA;
DRAWTEXT(FILTER(CROSS(0,MACD) OR CROSS(0,周MACD)
OR CROSS(0,中斜),5),H*1.05,'减')COLORGREEN;

V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
支撑:=REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;
阻力:=REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;
MA11:=MEMA(CLOSE,5);
MA2:=ATAN((MA11/REF(MA11,1)-1)*100)*180/3.1416;
MA3:=IF(MA2>0,MA2,MA2);
MA5:=MA(CLOSE,N),COLOR888899;
MA13:=MA(CLOSE,M),COLORFF00F0,LINETHICK2;
VAR18:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
C>=REF(C,1) AND C>=REF(C,2);
VAR28:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=CLOSE=LLV(C,4) AND (REF(C,1)< REF(C,2) OR REF(C,1)< REF(C,3)) OR
REF(C,1)=LLV(C,4) AND CREF(C,2) OR REF(C,2)=LLV(C,4) AND 
REF(C,1)=HHV(C,4) AND C< REF(C,1) OR REF(C,3)=LLV(C,4) AND

C< REF(C,1) AND CREF(C,2);
VAR4:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)=REF(C,1);
VAR5:=REF(C,1)=HHV(C,4) AND CREF(C,2) OR (REF(C,2)=HHV(C,4) AND
REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
REF(C,2)>=REF(C,4) AND C< REF(C,1);
VAR6:=V5>REF(V5,1) AND REF(V5,1)< REF(V5,2);
VAR7:=LOW< HHV(V5,13) AND H> HHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;

VAR8:=VAR7 AND COUNT(VAR6,2);
VAR9:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR9,2)=LLV(VAR9,7) AND COUNT(VAR9<0,2) AND
CROSS(VAR9,MA(VAR9,2)))=1,5);
VAR12:=FILTER((HHV(VAR9,2)=HHV(VAR9,7) AND COUNT(VAR9>50,2) AND
CROSS(MA(VAR9,2),VAR9))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR8 AND NOT(REF(VAR8,1));
强攻:=IF(MA3>REF(MA3,1) AND MA3>=0,MA13,DRAWNULL),COLORYELLOW,LINETHICK2;
回调:=IF(MA3< REF(MA3,1) AND MA3> 0,MA13,DRAWNULL),COLORGREEN,LINETHICK2;
{KDJ}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
买1:=(VAR14 OR VAR15) AND VAR11;
买2:=(VAR14 OR VAR15) AND VAR4;
买3:=(VAR14 OR VAR15) AND VAR28;
买4:=(VAR28 AND VAR11) OR (VAR4 AND VAR11);
买5:=(金叉 AND VAR4) OR (金叉 AND VAR28) OR (金叉 AND VAR11);
{涨停}
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),
COLOR00FFFF;
{跌停}
STICKLINE(CLOSE< REF(C,1)*1.0985 AND C=L,C,O,4,-1),COLORGREEN;
{蓝}
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.3,0),COLORFF6600;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.4,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.3,0),COLORFFBB00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.8,0),COLORFFDD00;
{红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.3,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0),COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.3,0),COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.8,0),COLOR0000FF;
{绿}   
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR009900;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.4,0),COLOR00BB00; 
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.3,0),COLOR00DD00;    
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.8,0),COLOR00FF00;
{灰}
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR999999;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;      
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.3,0),COLORDDDDDD;    
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.8,0),COLORFFFFFF;
STICKLINE(金叉,OPEN,CLOSE,0.6,0),COLORYELLOW;
STICKLINE(死叉,OPEN,CLOSE,0.6,0),COLOR000066;

DRAWICON(VAR16,LOW-0.02,7);
DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW*0.98,23);
DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9) AND C<趋势线,HIGH+0.01,2);

X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
EMA3:=EMA(C,3);
DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10),
LOW*0.99,'★∠45'),COLORFFFFFF;
STICKLINE(T91,C,O,3.5,0),COLOR00FFFF;
STICKLINE(T9,C,O,3.5,0),COLOR0000FF;
DRAWTEXT(T9,L*0.97,'全仓'),COLOR00FFFF;


投资市场成功的铁律:大道至简,简单的才是最有效的!只有简单才最具有操作性,只有简单才具有盈利的稳定性。真正造成你账户持续不断亏损,最大的罪魁祸首就是你太复杂:手多冲动,急躁拖拉,不服输无耐心,心存侥幸,逆势孤注一掷。实盘成功秘决是:简单合理进离场规则,机械重复,长期坚持。当你把简单本质做到了极致,必将成为实盘市场的永久大赢家。大道至简,实盘就是这么简单,只有到了这个境界才能实现财务自由。

势至简高智稳管道线突破系统最新版免费下载:(版本:81.02 大小: 8.20 MB 系统:windows )

势至简高智稳系统免费下载: 本地免费下载

简单到极致的买股神器,势至简高智稳管道线系统免费下载


本文地址:http://zhibiaolu.com/post/2272.html
温馨提示:本站所有资源均来自互联网,如果侵犯你的版权请通知本站,我们会在24小时内删除相关资源!

发表评论


表情

还没有留言,还不快点抢沙发?